Go Back   Mosets Community > Mosets Announcements and Discussions > Mosets & Joomla

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-28-2005, 08:31 PM
bauxite17 bauxite17 is offline
Junior Member
 
Join Date: Feb 2005
Posts: 1
Default Shout It! Error

Im using Mambo 4.5.2.1 and with Shout It! installed. It was finely running but suddenly, when it reach to 7 shouts, i'd received this error:

Fatal error: Call to a member function on a non-object in /home/bauxite17/public_html/mambo/includes/mambo.php on line 347

I dont know what's really the main problem. Please help....
Hoping for your reply...

regards,
Reply With Quote
  #2  
Old 03-10-2005, 02:02 AM
maybelogic maybelogic is offline
Junior Member
 
Join Date: Mar 2005
Posts: 1
Default Shout it 'refresh' error

"Not Found
The requested URL /mlaforum /index2.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I am using mambo with the 'shout it' module, it seem to work fantastic and it refreshs on its own just fine but when you press the refresh button you get the above error.

Do you all have any insight into this error?

Thanks

cody
Reply With Quote
  #3  
Old 05-30-2005, 10:21 AM
p9939068 p9939068 is offline
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Quote:
Originally Posted by bauxite17
Im using Mambo 4.5.2.1 and with Shout It! installed. It was finely running but suddenly, when it reach to 7 shouts, i'd received this error:

Fatal error: Call to a member function on a non-object in /home/bauxite17/public_html/mambo/includes/mambo.php on line 347

I dont know what's really the main problem. Please help....
Hoping for your reply...

regards,
This is exactly what i get. It happens totally random, and almost everytime when i try to refresh my home page. I set my shout it to auto refresh every 1 minute, and sometimes it will fail to refresh and display this error too. After playing around with the files, it seems to me to be a caching problem. I really hope mosets will find a way to fix it for 4.5.2.1, especially since shout it is currently mambo's only decent shoutbox that can be easily configured.
Reply With Quote
  #4  
Old 05-30-2005, 06:53 PM
duplo2222 duplo2222 is offline
Junior Member
 
Join Date: May 2005
Posts: 3
Default

I have the Same Problem since I installed the User Extended Component for Mambo. I can only use Shout It when the User is not logged in. As they are logged in the Shout It Box shows the error Posted by bauxite17. It seems like the Shout It component can not get the Usernames.
Reply With Quote
  #5  
Old 05-30-2005, 07:01 PM
p9939068 p9939068 is offline
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Yes i have also realised that the "log-in" state of Shout It! will become "Logged off" by itself everytime after i got the "Fatal error: Call to a member function on a non-object in /home/bauxite17/public_html/mambo/includes/mambo.php on line 347" error, which seems like the session timed out even though the user is still logged on, which made me suspect the caching problem, or could it be session handling?
Reply With Quote
  #6  
Old 05-30-2005, 07:10 PM
duplo2222 duplo2222 is offline
Junior Member
 
Join Date: May 2005
Posts: 3
Default

I have found this:

http://www.thegillis.net/programming..._with_fix.html

But i have no Idea how to Use the Fix?
Reply With Quote
  #7  
Old 05-30-2005, 08:21 PM
p9939068 p9939068 is offline
Junior Member
 
Join Date: May 2005
Posts: 4
Default

Quote:
Originally Posted by duplo2222
I have found this:

http://www.thegillis.net/programming..._with_fix.html

But i have no Idea how to Use the Fix?
Wow thank you so, so much for sharing that link! I've read through it, and this is simply what it means:

delete the code "$acl = new gacl_api();" at line 58/59 and move it to line 33/34 above the code "$mainframe = new mosMainFrame( $database, $option, '.' );". I'm testing in on my main site at the moment..everything looks ok, though that can be rhectoric hope it goes well
Reply With Quote
  #8  
Old 05-30-2005, 11:17 PM
duplo2222 duplo2222 is offline
Junior Member
 
Join Date: May 2005
Posts: 3
Default

That dosnt work at my site. I have Stil the error. But thanks for your help.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +8. The time now is 04:37 AM.

Copyright © 2005-2010 Mosets Consulting

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.