Go Back   Mosets Community > Archives > Mosets Hot Property 1.0 > Discussions, Troubleshooting and Problems

 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-12-2009, 05:42 AM
timothypsoulen timothypsoulen is offline
Mosets'd
 
Join Date: Mar 2009
Posts: 32
Default Help w/XMLThumb Gallery on Property Detail Page

Greetings,

I previously implemented the flash gallery imagerotator using the code provided by sergio in an earlier post to auto-generate an XML file for each property and it worked like a charm (thanks sergio!).

I want a flash gallery with thumbnails and am trying to implement XMLThumbGallery in the same fashion. I've successfully re-configured the code to generate the correctly formatted XML file for each property and I'm able to run it from a test.html file and confirm that it loads the correct images.

However, when I then take the same code and put it into the property/default.php file, it loads the flash just fine on the property detail page but it can't find the images.

I've compared the code on the page source of my test.html file with the code in the page source of the property detail page generated by the default.php file and everything looks the same - the path to the XML file is the same but I can't figure out why it loads the XML file when called from the text.html file but can't find it when called from the property detail page.

I am running this in a localhost environment, Joomal 1.5.8/HP 1.04b. See attached default.php file.

Again, the previous flash gallery, imagerotator, worked fine and this flash gallery works fine when called from a test.html file but not when generated via the php file even though the page source code on the index.html and php generated pages looks the same.

Any ideas? What am I missing?

Thanks!

Tim
Attached Files
File Type: php default.php (13.5 KB, 3 views)
  #2  
Old 04-12-2009, 06:04 PM
Stijn's Avatar
Stijn Stijn is offline
Mosets'd
 
Join Date: Oct 2006
Location: The Netherlands
Posts: 253
Default

I cannot find where you link to the right image directory.
Maybe you should look @ that.

Sergio altered the code for this also.

Stijn
__________________
www.trouwportaal.nl
Joomla 2.5.x and Mosets Tree 3.0.x
  #3  
Old 04-12-2009, 10:00 PM
christopherhegg's Avatar
christopherhegg christopherhegg is offline
Mosets'd
 
Join Date: Feb 2009
Location: Maryland, USA
Posts: 9
Default

Hey Tim not to sure on how to correct this issue but if you go back to the other Thread I did figure out how to get the Agent and Contact Agent Tabs to display information.

Chris
  #4  
Old 04-13-2009, 01:28 AM
timothypsoulen timothypsoulen is offline
Mosets'd
 
Join Date: Mar 2009
Posts: 32
Default

Quote:
Originally Posted by Stijn View Post
I cannot find where you link to the right image directory.
Maybe you should look @ that.

Sergio altered the code for this also.

Stijn
Thanks for the prompt response Stijn.

The php file generates the following code for the flash gallery on the property detail page (pulled from the page source of the property detail page):

<div id="flashcontainer"></div>

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="400" height="300" id="gallery" align="middle">
<param name="FlashVars" value="/xml2/1000.xml" />
<param name="allowScriptAccess" value="sameDomain" />
<param name="allowFullScreen" value="true" />
<param name="movie" value="/XMLThumbGallery/gallery.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#000000" />
<embed src="/XMLThumbGallery/gallery.swf" quality="high" bgcolor="#000000" width="400" height="300" name="gallery" align="middle" allowScriptAccess="sameDomain" allowFullScreen="true" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" FlashVars="/xml2/1000.xml" />
</object></div>

The 1000.xml file was autogenerated form the php file and is correctly formatted. For example, if I put the above code by itself into separate html file, then the flash gallery appears and pulls in the correct image files. So I in know the XML is correct and I know that I can point the flash gallery to the XML file and pull in the images. It's just not happening when the page is generated by the PHP file.

Any other ideas would be much appreciated!

Thanks!

--Tim
  #5  
Old 04-13-2009, 02:14 AM
timothypsoulen timothypsoulen is offline
Mosets'd
 
Join Date: Mar 2009
Posts: 32
Default

Follow-up:

OK, this is just weird. I copied the page source of the property detail page generated by the php file and saved it as a test2.html file at the root of the site. Then I opened it in a browser and everything is there except that the flash gallery can't find the images. If I then copy and paste just the flash gallery code from the test2.html file and save it by itself as test4.html then when I load test4.html in a browser the flash gallery loads and finds the images just fine. I've attached both files as txt files.

Is there something in the php file code that could be interfering?

Again, thanks for any help you can provide!

--Tim
Attached Files
File Type: txt test2.txt (16.4 KB, 2 views)
File Type: txt test4.txt (828 Bytes, 0 views)
  #6  
Old 04-14-2009, 11:53 PM
timothypsoulen timothypsoulen is offline
Mosets'd
 
Join Date: Mar 2009
Posts: 32
Default

Figured out my problem - in the HP PHP code it sets the base href in the header which messes up the path for the Flash calls. Modifying the Flash code to set the base href fixed the problem. For example, inserting in to the <object> tag:

<param name="base" value="http://mysite.com/pathtoflashfiles/" />

and then in the <embed> tag adding:

base="http://mysite.com/pathtoflashfiles"
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I have two detail page templates ? kevinman77 Discussions, Troubleshooting and Problems 1 10-08-2008 05:37 PM


All times are GMT +8. The time now is 11:29 AM.

Copyright © 2005-2010 Mosets Consulting

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.