Go Back   Mosets Community > Archives > Mosets Hot Property 1.0 > Discussions, Troubleshooting and Problems

 
 
Thread Tools Search this Thread Display Modes
  #61  
Old 02-07-2009, 10:57 PM
popamarianpfa popamarianpfa is offline
Mosets'd
 
Join Date: Jan 2009
Posts: 9
Default

thanks
  #62  
Old 02-07-2009, 11:08 PM
popamarianpfa popamarianpfa is offline
Mosets'd
 
Join Date: Jan 2009
Posts: 9
Default

Quote:
Originally Posted by ioannisssoultanidi View Post
Well i use your hack and everything it's ok.
Thanks it's great.

But, i have one small problem.
I give the longitude and latitude in the property (i add the extra fields)
and the map shows nothing.

You can see it at http://www.hellohellas.eu/index.php?...id=110&lang=en
So how did you put extra fields here?
http://www.hellohellas.eu/index.php?...id=110&lang=en
  #63  
Old 09-23-2009, 05:59 PM
blahblahblah blahblahblah is offline
Mosets'd
 
Join Date: Mar 2007
Posts: 8
Default Working?

Great thread! I've been following and tonight sat down to try my hand. I have HP 1.04b, and J! 1.5.14.

4 hours later, I do not have the images loading and I've re-read several times and double-checked the posts. One of the inconsistencies I have found is that the jw-image-rotator [ http://www.longtailvideo.com/players/jw-image-rotator/ ] does not contain an "imagerotator.xml" file. The instructions say: Step 1: Transfer the imagerotator.swf and imagerotator.xml file from the ZIP to your website.

I include a screenshot (oncludes_js.png) of the /includes/js/ folder on the server, and also a screenshot (local_folder.png) of the working folder on my desktop. You will note that the files in green are the ones I uploaded to /includes/js folder on the server.

Note 2 important things: 1. imagerotator.xml is not present; 2. swfobject.js and video.flv have similar names, so only one or the other can reside on the server. I've tried both versions and that did not solve.

Hopefully someone can clarify the files and steps they used to get their jw-image-rotator and jw-mediaplayer working. Thank you.

EDIT --> I was able to get the images working and the xml files created with ssaguir's great tutorial. But I have since decided to change to SlideShowPro for Flash as the image viewer, so disregard this post.
Attached Images
File Type: png includes_js.png (47.0 KB, 41 views)
File Type: png local_folder.png (62.8 KB, 39 views)

Last edited by blahblahblah; 09-27-2009 at 03:43 PM.
  #64  
Old 10-01-2009, 09:46 AM
tanyarshelton tanyarshelton is offline
Mosets'd
 
Join Date: Oct 2009
Posts: 1
Default

Hello blahblahblah.

I purchased slideshowpro for flash. Would you mind explaining how you integrated it into Hot Property? That would be great!!!

Thanks
  #65  
Old 10-01-2009, 11:23 AM
blahblahblah blahblahblah is offline
Mosets'd
 
Join Date: Mar 2007
Posts: 8
Default

Hello tanyarshelton,

While I have gone with what I consider to be a better presentation for the photos, I have yet been able to figure out how to get it to work. I currently have it loading the swf file, but it is not dynamically creating the XML files as I need. I'm hoping at some point ssaguiar will email me back and or post his most recent default file. I will follow up on the board if I get it working.
  #66  
Old 01-26-2010, 09:46 PM
ssaguiar ssaguiar is offline
Mosets'd
 
Join Date: Apr 2008
Posts: 143
Default

Dear friends:

I am experimenting serious problems, this is why I am taking some more time to answer to everybody.

I use the slideshowpro.

Warning: This works with the version I have of HP, I don't know if it will work with the last one.

First of all, you must create a folder, in your home, called xml.
Then, you must put the slideshowpro files in this folder (param.xml, slideshowpro.swf and swfobject.js).

My param.xml file's content is:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<params>
<customParams                
	navButtonStyle = "Default"
/>
<nativeParams
	albumBackgroundAlpha = "1"
	albumBackgroundColor = "0x303030"
	albumDescColor = "0xCCCCCC"
	albumDescSize = "9"
	albumPadding = "8"
	albumPreviewScale = "Proportional"
	albumPreviewSize = "54,41"
	albumPreviewStrokeColor = "0xFFFFFF"
	albumPreviewStrokeWeight = "1"
	albumPreviewStyle = "Inline Left"
	albumRolloverColor = "0x262626"
	albumStrokeAppearance = "Visible"
	albumStrokeColor = "0x141414"
	albumTextAlignment = "Left"
	albumTitleColor = "0xFFFFFF"
	albumTitleSize = "10"
	audioAutoStart = "On"
	audioLoop = "Off"
	audioPause = "Off"
	audioVolume = ".8"
	autoFinishMode = "Switch"
	cacheContent = "None"
	captionAppearance = "Overlay on Rollover (if Available)"
	captionBackgroundAlpha = ".75"
	captionBackgroundColor = "0x000000"
	captionHeaderBackgroundAlpha = ".75"     
	captionElements = "Header and Caption"
	captionHeaderText = "{imageTitle}"
	captionPadding = "5,5,5,5"
	captionPosition = "Top"
	captionTextAlignment = "Left"
	captionTextColor = "0xEEEEEE"
	captionTextSize = "9"
	contentAlign = "Center"
	contentAreaAction = "Launch Hyperlink"
	contentAreaBackgroundAlpha = "1"
	contentAreaBackgroundColor = "0x303030"
	contentAreaInteractivity = "Action Area Only"
	contentAreaStrokeAppearance = "Visible"
	contentAreaStrokeColor = "0x262626"
	contentFrameAlpha = "1"
	contentFrameColor = "0x262626"
	contentFramePadding = "0"
	contentFrameStrokeAppearance = "Hidden"
	contentFrameStrokeColor = "0x333333"
	contentOrder = "Sequential"
	contentScale = "Downscale Only"
	contentScalePercent = "1"
	directorLargePublishing = "On"
	directorLargeQuality = "80"
	directorLargeSharpening = "1"
	directorThumbQuality = "60"
	directorThumbSharpening = "1"
	displayMode = "Auto"
	feedbackBackgroundAlpha = ".3"
	feedbackBackgroundColor = "0x000000"
	feedbackHighlightAlpha = ".8"
	feedbackHighlightColor = "0xFFFFFF"
	feedbackPreloaderAlign = "Center"
	feedbackPreloaderAppearance = "Beam"
	feedbackPreloaderPosition = "Inside Content Area"
	feedbackPreloaderScale = "1"
	feedbackPreloaderTextSize = "12"
	feedbackTimerAlign = "Top Right"
	feedbackTimerAppearance = "Visible"
	feedbackTimerPosition = "Inside Content Area"
	feedbackTimerScale = "1" 
	feedbackVideoButtonScale = "1"
	fullScreenReformat = "On"
	fullScreenTakeOver = "On"
	galleryAppearance = "Visible"
	galleryBackgroundAlpha = "1"
	galleryBackgroundColor = "0x1C1C1C"
	galleryColumns = "2"
	galleryOrder = "Left to Right"
	galleryPadding = "10"
	galleryRows = "4"
	galleryNavActiveColor = "0x303030"
	galleryNavAppearance = "Visible"
	galleryNavInactiveColor = "0x000000"
	galleryNavRolloverColor = "0x262626"
	galleryNavStrokeAppearance = "Visible"
	galleryNavStrokeColor = "0x141414"
	galleryNavTextColor = "0xCCCCCC"
	galleryNavTextSize = "9"
	keyboardControl = "On"
	mediaPlayerAppearance = "Visible on Rollover"
	mediaPlayerBackgroundAlpha = ".25"
	mediaPlayerBackgroundColor = "0x000000"
	mediaPlayerBufferColor = "0x000000"
	mediaPlayerButtonColor = "0xFFFFFF"
	mediaPlayerButtonShadowAlpha = ".6"
	mediaPlayerElapsedBackgroundColor = "0xFFFFFF"
	mediaPlayerElapsedTextColor = "0x000000"
	mediaPlayerPosition = "Bottom"
	mediaPlayerProgressColor = "0xCCCCCC"
	mediaPlayerScale = ".8"
	mediaPlayerTextColor = "0x999999"
	mediaPlayerTextSize = "9"
	mediaPlayerVolumeBackgroundColor = "0x000000"
	mediaPlayerVolumeHighlightColor = "0xCCCCCC"
	navAppearance = "Always Visible"
	navBackgroundAlpha = "1"
	navBackgroundColor = "0x121212"     
	navButtonColor = "0xEEEEEE"
	navButtonInactiveAlpha = ".4"
	navButtonsAppearance = "All Visible"
	navButtonShadowAlpha = ".6"
	navGradientAlpha = ".3"
	navGradientAppearance = "Glass Dark"
	navLinkAppearance = "Thumbnails"
	navLinkCurrentColor = "0xEEEEEE"
	navLinkPreviewAppearance = "Visible"
	navLinkPreviewBackgroundAlpha = "1"
	navLinkPreviewBackgroundColor = "0xFFFFFF"
	navLinkPreviewScale = "Proportional"
	navLinkPreviewSize = "80,60"
	navLinkPreviewStrokeWeight = "1"
	navLinkRolloverColor = "0xFFFFFF"
	navLinksBackgroundAlpha = "1"
	navLinksBackgroundColor = "0x000000"
	navLinkSpacing = "10"
	navNumberLinkColor = "0x999999"
	navNumberLinkSize = "9"
	navPosition = "Bottom"
	navThumbLinkBackgroundColor = "0x666666"
	navThumbLinkInactiveAlpha = "1"
	navThumbLinkShadowAlpha = ".6"
	navThumbLinkSize = "20,20"
	navThumbLinkStrokeWeight = "1"
	panZoom = "On"
	panZoomDirection = "Random"
	panZoomFinish = "Off"
	panZoomScale = "1,1.2"
	permalinks = "Off"
	smoothing = "On"
	startup = "Load Album"
	textStrings = "Previous Screen,Next Screen,Screen,of,No caption,No title,Playing,Paused,Click play to start audio"           
	toolAppearanceContentArea = "Hidden"
	toolAppearanceNav = "Visible"
	toolColor = "0x222222"
	toolDelayContentArea = "0"
	toolDelayNav = ".5"
	toolLabels = "Gallery,Previous Group,Previous,Next,Next Group,Pause,Play,Full Screen,Normal Screen,Open Link"
	toolTextColor = "0xEEEEEE"
	toolTextSize = "9"
	toolTimeoutContentArea = "0"
	transitionLength = "2"
	transitionPause = "4"
	transitionDirection = "Left to Right"
	transitionStyle = "Cross Fade"
	typeface = "Lucida Grande,Lucida Sans Unicode,Verdana,Arial,_sans"
	typefaceEmbed = "Off"
	typefaceHead = "Lucida Grande,Lucida Sans Unicode,Verdana,Arial,_sans"
	videoAutoStart = "Off"
	videoBufferTime = "5"
	xmlFilePath = "images.xml"
	xmlFileType = "Default"
/>
</params>
The code to show the pictures, must be placed in the file (for the version I have ver 1.0 beta1, I think):
/components/com_hotproperty/views/property/tmpl/default.php

In the place where you want to have your pictures seen, put this code:

Code:
	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="400" height="340" id="loader" align="middle">
	<param name="allowScriptAccess" value="sameDomain" />
	<param name="allowFullScreen" value="true" />
	<param name="FlashVars" value="xmlFilePath=http://www.ssaguiar.com/xml/<?php echo($this->p->id.'.xml'); ?>&xmlfiletype=Default&paramXMLPath=/xml/param.xml" />
	<param name="base" value="." />
	<param name="movie" value="/xml/slideshowpro.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#121212" />	<embed base="." FlashVars="xmlFilePath=http://www.ssaguiar.com/xml/<?php echo($this->p->id.'.xml'); ?>&xmlfiletype=Default&paramXMLPath=/xml/param.xml" src="/xml/slideshowpro.swf" quality="best" bgcolor="#121212" width="400" height="340" name="loader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="true" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
	</object>
Remember to change
Code:
http://www.ssaguiar.com/
to your site's address.

Before that, you must create the xml files of the pictures dynamically, if they are not already created:
Code:
					      <?php
                $filename = '/home/ssaguiar/public_html/xml/'.$this->p->id.'.xml';
                
                if ( !file_exists($filename))
                {            
                    $somecontent='<?xml version="1.0" encoding="UTF-8"?>'."\n";
                    $somecontent=$somecontent.'<gallery>'."\n";
                    $somecontent=$somecontent."\t".'<album id="Imovel" lgPath="/'.$hp_imgdir_standard.DS.'" tnPath="/'.$hp_imgdir_thumb.DS.'" title="'.$this->p->type.'" description="'.$this->p->name.'" tn="/'.$hp_imgdir_thumb.DS.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'">'."\n";
                    
                    if (!empty($this->images))
                    {
                        foreach($this->images AS $image)
                        {
														$somecontent=$somecontent."\t\t".'<img src="'.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'" title="" caption="" link="" target="_blank" pause="" vidpreview="" />'."\n";
                        }
                        $somecontent=$somecontent."\t".'</album>'."\n";
                        $somecontent=$somecontent.'</gallery>';
                        touch($filename) or die("Unable to create: " . $filename);
                        $handle = fopen($filename, 'a') or die("Could not open file: " . $filename . "\n");
                        fwrite($handle, $somecontent) or die("Could not write to file: " . $filename . "\n");
                        fclose($handle);
                    }
                }
                ?>
Again, remember to change the address to your site's address.

So the code is:
Code:
					      <?php
                $filename = '/home/ssaguiar/public_html/xml/'.$this->p->id.'.xml';
                
                if ( !file_exists($filename))
                {            
                    $somecontent='<?xml version="1.0" encoding="UTF-8"?>'."\n";
                    $somecontent=$somecontent.'<gallery>'."\n";
                    $somecontent=$somecontent."\t".'<album id="Imovel" lgPath="/'.$hp_imgdir_standard.DS.'" tnPath="/'.$hp_imgdir_thumb.DS.'" title="'.$this->p->type.'" description="'.$this->p->name.'" tn="/'.$hp_imgdir_thumb.DS.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'">'."\n";
                    
                    if (!empty($this->images))
                    {
                        foreach($this->images AS $image)
                        {
														$somecontent=$somecontent."\t\t".'<img src="'.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'" title="" caption="" link="" target="_blank" pause="" vidpreview="" />'."\n";
                        }
                        $somecontent=$somecontent."\t".'</album>'."\n";
                        $somecontent=$somecontent.'</gallery>';
                        touch($filename) or die("Unable to create: " . $filename);
                        $handle = fopen($filename, 'a') or die("Could not open file: " . $filename . "\n");
                        fwrite($handle, $somecontent) or die("Could not write to file: " . $filename . "\n");
                        fclose($handle);
                    }
                }
                ?>


	<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="400" height="340" id="loader" align="middle">
	<param name="allowScriptAccess" value="sameDomain" />
	<param name="allowFullScreen" value="true" />
	<param name="FlashVars" value="xmlFilePath=http://www.ssaguiar.com/xml/<?php echo($this->p->id.'.xml'); ?>&xmlfiletype=Default&paramXMLPath=/xml/param.xml" />
	<param name="base" value="." />
	<param name="movie" value="/xml/slideshowpro.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#121212" />	<embed base="." FlashVars="xmlFilePath=http://www.ssaguiar.com/xml/<?php echo($this->p->id.'.xml'); ?>&xmlfiletype=Default&paramXMLPath=/xml/param.xml" src="/xml/slideshowpro.swf" quality="best" bgcolor="#121212" width="400" height="340" name="loader" align="middle" allowScriptAccess="sameDomain" allowFullScreen="true" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
	</object>
This will show your pictures as seen in my site:
http://www.ssaguiar.com/index.php?op...d=13&Itemid=77

Hope this help.

Sergio
  #67  
Old 01-27-2010, 06:32 AM
Afanarenko Afanarenko is offline
Junior Member
 
Join Date: Sep 2009
Posts: 4
Default

Quote:
Originally Posted by ssaguiar View Post
Dear friends:



Before that, you must create the xml files of the pictures dynamically, if they are not already created:

So the code is:


How to create xml files and how many? Where all the code?
  #68  
Old 01-27-2010, 07:50 AM
ssaguiar ssaguiar is offline
Mosets'd
 
Join Date: Apr 2008
Posts: 143
Default

Quote:
Originally Posted by Afanarenko View Post
How to create xml files and how many? Where all the code?
You can see the code in my post above.
See:

Code:
					      <?php
                $filename = '/home/ssaguiar/public_html/xml/'.$this->p->id.'.xml';
                
                if ( !file_exists($filename))
                {            
                    $somecontent='<?xml version="1.0" encoding="UTF-8"?>'."\n";
                    $somecontent=$somecontent.'<gallery>'."\n";
                    $somecontent=$somecontent."\t".'<album id="Imovel" lgPath="/'.$hp_imgdir_standard.DS.'" tnPath="/'.$hp_imgdir_thumb.DS.'" title="'.$this->p->type.'" description="'.$this->p->name.'" tn="/'.$hp_imgdir_thumb.DS.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'">'."\n";
                    
                    if (!empty($this->images))
                    {
                        foreach($this->images AS $image)
                        {
														$somecontent=$somecontent."\t\t".'<img src="'.(($image->standard <> '') ? $image->standard : $hp_img_noimage_thumb).'" title="" caption="" link="" target="_blank" pause="" vidpreview="" />'."\n";
                        }
                        $somecontent=$somecontent."\t".'</album>'."\n";
                        $somecontent=$somecontent.'</gallery>';
                        touch($filename) or die("Unable to create: " . $filename);
                        $handle = fopen($filename, 'a') or die("Could not open file: " . $filename . "\n");
                        fwrite($handle, $somecontent) or die("Could not write to file: " . $filename . "\n");
                        fclose($handle);
                    }
                }
                ?>
This will generate the files in the xml folder.
Just remember to change your site's address. In place of:
Code:
$filename = '/home/ssaguiar/public_html/xml/'.$this->p->id.'.xml';
put:
Code:
$filename = '/absolutepathtohomeofyoursite/xml/'.$this->p->id.'.xml';
Sergio
  #69  
Old 01-27-2010, 02:47 PM
ssnobben ssnobben is offline
Mosets'd
 
Join Date: Nov 2006
Posts: 805
Thumbs up

Thanks for making this efforts Sergio..Do you mean this Slideshow Pro - EasySSP - SlideShowPro for Joomla!?

http://extensions.joomla.org/extensi...-channels/5280

I will test this later. Do you have a demo on your site where you put this up?

rgds
__________________
Success in the long run Its not about the code its about the people and community that's make it!
  #70  
Old 01-27-2010, 03:47 PM
Afanarenko Afanarenko is offline
Junior Member
 
Join Date: Sep 2009
Posts: 4
Default

I tried to HP RC1. I have only a gray box and nothing else. Why?

At RC1 gallery as plug in.

Sergio can do plug in for RC1?
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +8. The time now is 01:41 AM.

Copyright © 2005-2010 Mosets Consulting

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.