Go Back   Mosets Community > Mosets Tree 3.x > Discussions, Troubleshooting & Problems

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-01-2015, 10:34 AM
ucehongkongltdmead ucehongkongltdmead is offline
Mosets'd
 
Join Date: Mar 2015
Posts: 1
Default profile picture error in joomla3.4

i am still unable to upload a user profile image using Joomla 3.4 and Mosets Tree 3.5.12 - the error message is still:
Save failed with the following error: No valid image was loaded.

I checked the page code in accord with earlier posts ref Joomla 2.5 but this did not make a difference.

Has anyone seen the same error and found a fix?
Reply With Quote
  #2  
Old 05-16-2015, 01:54 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default Fatal Error

I'm having the same problem, I can't upload pictures.

Fatal error: Class 'ProfilePicture' not found in /home/resumos0/public_html/---.info/components/com_mtree/mtree.php on line 2577
Reply With Quote
  #3  
Old 05-31-2015, 08:07 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default Error

Ok, I made sure everything is installed correctly and I'm getting another error when trying to upload a picture. Anyone has a suggestion on how to fix this problem?

An error has occurred.

0 SplFileInfo::__construct() expects parameter 1 to be string, array given

I installed:

- lib_mosets_profilepicture-1.0
- plg_user_profilepicture-1.2.0

I'm using latest versions of Joomla and Mosets Tree.

This error happens in the administrator area and in the user area too.
Reply With Quote
  #4  
Old 05-31-2015, 08:24 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default No Valide Image

I was reading that the error:

0 SplFileInfo::__construct() expects parameter 1 to be string, array given with

was related to a plugin called JHackGuard Plugin.

I disabled the plugin and now when I try to upload a picture I get this message:

No valid image was loaded.
Reply With Quote
  #5  
Old 06-15-2015, 05:31 PM
dknight dknight is offline
Mosets Team - Lead Developer
 
Join Date: Dec 2004
Posts: 26,302
Default

I've recently updated and release Profile Picture 2.0 for Joomla 3. Give that a try:

https://github.com/mosets/profilepicture/releases
__________________
Lee
Lead Developer
Mosets.com - Quality Joomla! Solutions
Reply With Quote
  #6  
Old 06-16-2015, 12:06 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default Error

I installed the new version and I have this error when I try to see a listing.

Fatal error: Class 'ProfilePicture' not found in /home/resumos0/public_html/artigos.info/components/com_mtree/mtree.php on line 2701
Reply With Quote
  #7  
Old 06-16-2015, 11:18 AM
dknight dknight is offline
Mosets Team - Lead Developer
 
Join Date: Dec 2004
Posts: 26,302
Default

I can think of 2 possible issues.

- Profile Plugin library is not installed or enabled
- You're not running MT 3.6.1.

Check you can on both?
__________________
Lee
Lead Developer
Mosets.com - Quality Joomla! Solutions
Reply With Quote
  #8  
Old 06-16-2015, 11:40 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default

Profile plugin library is installed and enabled
I'm running MT 3.6.1.

And now the owner listing page shows the same thing:

admin

Fatal error: Class 'ProfilePicture' not found in /home/resumos0/public_html/artigos.info/components/com_mtree/templates/kinabalu/sub_ownerProfile.tpl.php on line 17

But it's working better now, I was able to upload a picture.

Last edited by Ricardo; 06-16-2015 at 11:41 AM. Reason: pic
Reply With Quote
  #9  
Old 06-16-2015, 11:43 AM
dknight dknight is offline
Mosets Team - Lead Developer
 
Join Date: Dec 2004
Posts: 26,302
Default

Ricardo,

please open a private support thread with access to your site's back-end and FTP. I'll take a closer look at this.
__________________
Lee
Lead Developer
Mosets.com - Quality Joomla! Solutions
Reply With Quote
  #10  
Old 06-16-2015, 11:56 AM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default Ok

Sent. Thanks!
Reply With Quote
  #11  
Old 06-16-2015, 01:27 PM
dknight dknight is offline
Mosets Team - Lead Developer
 
Join Date: Dec 2004
Posts: 26,302
Default

Try this workaround.

/components/com_mtree/mtree.php

Replacing:
PHP Code:
                jimport('profilepicture.profilepicture'); 
with:
PHP Code:
                jimport('mosets.profilepicture'); 
will fix the issue.
__________________
Lee
Lead Developer
Mosets.com - Quality Joomla! Solutions

Last edited by dknight; 06-16-2015 at 02:33 PM.
Reply With Quote
  #12  
Old 06-16-2015, 07:34 PM
Ricardo Ricardo is offline
Mosets'd
 
Join Date: Apr 2006
Posts: 141
Default Thanks

It's working now. Thanks!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Picture profile chaoto Discussions, Troubleshooting & Problems 1 12-20-2013 09:43 PM
Integrating JomSocial profile in Mosets Listing bethgardner Discussions, Troubleshooting & Problems 9 07-10-2013 08:54 PM
Hide profile picture woutervanderzeijde Discussions, Troubleshooting & Problems 5 04-17-2013 02:57 AM
Picture size goble Kinabalu 9 08-05-2010 08:56 AM


All times are GMT +8. The time now is 05:42 AM.

Copyright © 2005-2010 Mosets Consulting

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.